Resultados para la etiqueta funciones

PorLucía Montero Rodríguez

Aprovecha la potencia de los nombres de rango dinámicos

Si trabajas habitualmente con Excel, es probable que hayas podido comprobar lo útiles que resultan los nombres de rango a la hora de aportar claridad a una hoja de cálculo.

No obstante, cuando trabajamos con tablas o listas que, normalmente, van creciendo puede parecer que el uso de nombres de rango no es adecuado. Sin embargo, sí que es posible, combinando esta característica con funciones. Así que veámoslo 🙂

El proceso de creación

Vamos a utilizar un ejemplo sencillo que nos permite detectar cómo el nombre de rango se expande automáticamente. Para ello, empezamos escribiendo distintas cantidades numéricas en una hoja de cálculo. Por ejemplo: Leer más

PorLucía Montero Rodríguez

Buscar correspondencias en Excel

Como no nos asusta casi nada, anteriormente vimos cómo era posible realizar búsquedas cruzadas en Excel empleando funciones lógicas y de búsqueda.

Hoy vamos a realizar la misma tarea utilizando dos funciones completamente distintas que pertenecen a la categoría Búsqueda y Referencia: Indice() y Coincidir().

Con el objetivo de ayudar a esclarecer el funcionamiento de las mismas, tomaremos como base el siguiente modelo:

Tabla de correspondencias en Excel Leer más

PorLucía Montero Rodríguez

Búsquedas para tablas de referencias cruzadas

En ocasiones puede ser interesante encontrar la información correspondiente al cruce entre el dato de una fila y una columna de una tabla.

Si sólo empleamos una función SI(), podemos anidar y volver a anidar una dentro de otra, pero se convertiría en una fórmula muy larga y farragosa, así que una solución es combinar SI() con una función de búsqueda como por ejemplo BUSCARV().

Busqueda cruzada en Excel

En el ejemplo anterior, al escribir un determinado tipo de menú y una gama en la celda G2 aparece el precio correspondiente, como resultado de la función:

=SI(F2="vegetariano";BUSCARV(E2;A2:C4;2;0);BUSCARV(E2;A2:C4;3;0))

La dinámica ha sido preguntar por el primero de los encabezados de columna, por ejemplo, si es Vegetariano busco la gama en la primera columna de la tabla, y que me devuelva el dato correspondiente de la segunda; de lo contrario, devolverá el de la tercera, el correspondiente al menú Carnívoro.

Leer más